0%

HDU 2063 过山车 (匈牙利算法)

HDU 2063 过山车 (匈牙利算法)

题目链接:HDU 2063

Problem Description

RPG girls今天和大家一起去游乐场玩,终于可以坐上梦寐以求的过山车了。可是,过山车的每一排只有两个座位,而且还有条不成文的规矩,就是每个女生必须找个个男生做partner和她同坐。但是,每个女孩都有各自的想法,举个例子把,Rabbit只愿意和XHD或PQK做partner,Grass只愿意和linle或LL做partner,PrincessSnow愿意和水域浪子或伪酷儿做partner。考虑到经费问题,boss刘决定只让找到partner的人去坐过山车,其他的人,嘿嘿,就站在下面看着吧。聪明的Acmer,你可以帮忙算算最多有多少对组合可以坐上过山车吗?

Input

输入数据的第一行是三个整数K , M , N,分别表示可能的组合数目,女生的人数,男生的人数。0<K<=1000
1<=N 和M<=500.接下来的K行,每行有两个数,分别表示女生Ai愿意和男生Bj做partner。最后一个0结束输入。.

Output

对于每组数据,输出一个整数,表示可以坐上过山车的最多组合数。

Sample Input

1
2
3
4
5
6
7
8
6 3 3
1 1
1 2
1 3
2 1
2 3
3 1
0

Sample Output

1
3

Source

RPG专场练习赛

Solution

题意

如题。

思路

二分图最大匹配。

可以用最大流解决。也可以用匈牙利算法。匈牙利算法是最大流方法的一种优化。若采用邻接矩阵存图,时间复杂度 $O(V^2)$,空间复杂度 $O(V^2)$。若采用邻接表,时间复杂度 $O(VE)$,空间复杂度 $O(V+E)$。

Code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
#include <bits/stdc++.h>
using namespace std;
const int maxn = 510;

int n, m;
int g[maxn][maxn];
int vis[maxn], ok[maxn];

bool dfs(int x) {
for(int i = 1; i <= n; ++i) {
if(!vis[i] && g[x][i]) {
vis[i] = 1;
if(!ok[i] || dfs(ok[i])) {
ok[i] = x;
return true;
}
}
}
return false;
}

int main() {
ios::sync_with_stdio(false);
cin.tie(0);
int k;
while(cin >> k && k) {
cin >> m >> n;
memset(g, 0, sizeof(g));
memset(ok, 0, sizeof(ok));
for(int i = 0; i < k; ++i) {
int a, b;
cin >> a >> b;
g[a][b] = 1;
}
int sum = 0;
for(int i = 1; i <= m; ++i) {
memset(vis, 0, sizeof(vis));
if(dfs(i)) ++sum;
}
cout << sum << endl;
}
return 0;
}

欢迎关注我的其它发布渠道